Excel вставляем сумму ячеек на другой лист

Excel вставляем сумму ячеек на другой лист
2014-04-17 08:49:59
Подробное описание

Как известно, для отображения суммы некоторого диапазона ячеек в Microsoft Office Excel используется формула вида:

=СУММ(A10:A20)


Числа 10 и 20 являются номерами необходимых ячеек. Достаточно подставить нужный диапазон и в предполагаемом месте вывода суммы, отобразится данная информация.

Однако, для того, чтобы вывести сумму ячеек на другом листе, к примеру на Листе2, необходимо добавить в вышеуказанную формулу заголовок листа с нужным диапазоном. Практически это выглядит так:

=СУММ(Лист1!A10:A20)

Таким образом, мы получаем сумму чисел в ячейках от A10 до A20 включительно, расположенные на Листе1.
Что хорошо, если в будущем Лист1 будет редактироваться, а именно возникнет необходимость добавления некоторых ячеек в указанном диапазоне, значения формулы на Листе2 также, будут автоматически подменяться.

Пример!

У нас есть 2 листа: Лист1 и Лист2.
На первом листе в диапазоне A10:A20 мы указываем количество.
На втором листе в специальной ячейке мы хотим вывести общую сумму ячеек A10:A20. Для этого пишем формулу =СУММ(Лист1!A10:A20) - таким образом получили сумму всех указанных ячеек.

Допустим нам нужно добавить еще одну строку в диапазон A10:A20 на Листе1. Т.е. теперь у нас 11 ячеек.
Здесь есть важная особенность: добавление нужно производить только в указанном диапазоне ячеек. Например, между A15 и A16 вставляем строку. Диапазон сместится, но и формула на Листе2 изменится.

В этом случае на втором листе не придется ничего редактировать, потому как формула изменится автоматически. Для того, чтобы убедиться в этом, перейдем к ячейке с выводом общей суммы на Листе2 и увидим, что значения изменились на A10:A21.

И еще, если пришлось удалить некоторые ячейки из первого листа, то в этом случае нужно зайти на Лист2 и изменить диапазон вручную.

 

 

Добавить в закладки